<!DOCTYPE html>

<!--[if IE 8]> <html class="ie ie8" lang="en-GB"> <![endif]-->
<!--[if IE 9]> <html class="ie ie9" lang="en-GB"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-GB"> <!--<![endif]-->

<head>


<meta charset="UTF-8" />
<title>  Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;</title>

 
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="pingback" href="https://www.theedgesusu.co.uk/xmlrpc.php" />
	
<link rel="shortcut icon" href="https://www.theedgesusu.co.uk/wp-content/uploads/2014/11/favicon.png" />	

<link rel="apple-touch-icon-precomposed" href="https://www.theedgesusu.co.uk/wp-content/uploads/2015/03/mobile-icon.png" />
	
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Edge &raquo; Feed" href="https://www.theedgesusu.co.uk/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Edge &raquo; Comments Feed" href="https://www.theedgesusu.co.uk/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Edge &raquo; Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217; Comments Feed" href="https://www.theedgesusu.co.uk/records/albums/2020/12/22/lacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.13.3 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
    (window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
	var mi_version         = '7.13.3';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-146182477-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-146182477-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.theedgesusu.co.uk\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='avatars-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/add-local-avatar/avatars.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='imgareaselect-css'  href='https://www.theedgesusu.co.uk/wp-includes/js/imgareaselect/imgareaselect.css?ver=0.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.theedgesusu.co.uk/wp-includes/css/dashicons.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.theedgesusu.co.uk/wp-includes/js/thickbox/thickbox.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.theedgesusu.co.uk/wp-includes/css/dist/block-library/style.min.css?ver=5.6' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-night-mode-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/wp-night-mode/public/css/wp-night-mode-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='monsterinsights-popular-posts-style-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/google-analytics-for-wordpress/assets/css/frontend.min.css?ver=7.13.3' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400,600,700|Roboto+Slab' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-core-css'  href='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag-child/style.css?ver=2.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-responsive-css'  href='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/css/responsive.css?ver=2.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='pretty-photo-css'  href='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/css/prettyPhoto.css?ver=2.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-font-awesome-css'  href='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/css/fontawesome/css/font-awesome.min.css?ver=2.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='msl-main-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/master-slider/public/assets/css/masterslider.main.css?ver=3.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='msl-custom-css'  href='https://www.theedgesusu.co.uk/wp-content/uploads/master-slider/custom.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-skin-css'  href='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/css/skin-light.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='custom-css-css'  href='https://www.theedgesusu.co.uk/?anchor_obj=17&#038;bunyad_custom_css=1&#038;ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/jetpack/css/jetpack.css?ver=9.2.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<!--[if lt IE 8]>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/json2.min.js?ver=2015-05-03' id='json2-js'></script>
<![endif]-->
<script type='text/javascript' id='live-blogging-js-extra'>
/* <![CDATA[ */
var live_blogging = {"ajaxurl":"https:\/\/www.theedgesusu.co.uk\/wp-admin\/admin-ajax.php","update_effect":"top"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/live-blogging/live-blogging.min.js?ver=5.6' id='live-blogging-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.theedgesusu.co.uk","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.13.3' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' id='wp-night-mode-js-extra'>
/* <![CDATA[ */
var wpnmObject = {"button_html":"<div class=\"wpnm-button style-2\">\n                            <div class=\"wpnm-button-inner-left\"><\/div>\n                            <div class=\"wpnm-button-inner\"><\/div>\n                        <\/div>","default":"","server_time":"1608653872","turn_on_time":"","turn_off_time":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/wp-night-mode/public/js/wp-night-mode-public.js?ver=1.0.0' id='wp-night-mode-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/wp-retina-2x//app/picturefill.min.js?ver=1606142869' id='wr2x-picturefill-js-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/js/jquery.prettyPhoto.js?ver=5.6' id='pretty-photo-smartmag-js'></script>
<link rel="https://api.w.org/" href="https://www.theedgesusu.co.uk/wp-json/" /><link rel="alternate" type="application/json" href="https://www.theedgesusu.co.uk/wp-json/wp/v2/posts/166654" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.theedgesusu.co.uk/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.theedgesusu.co.uk/wp-includes/wlwmanifest.xml" /> 
<link rel="canonical" href="https://www.theedgesusu.co.uk/records/albums/2020/12/22/lacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird/" />
<link rel='shortlink' href='https://wp.me/p14ybt-HlY' />
<link rel="alternate" type="application/json+oembed" href="https://www.theedgesusu.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Frecords%2Falbums%2F2020%2F12%2F22%2Flacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.theedgesusu.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Frecords%2Falbums%2F2020%2F12%2F22%2Flacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird%2F&#038;format=xml" />
        <style>
        .getty.aligncenter {
            text-align: center;
        }
        .getty.alignleft {
            float: none;
            margin-right: 0;
        }
        .getty.alignleft > div {
            float: left;
            margin-right: 5px;
        }
        .getty.alignright {
            float: none;
            margin-left: 0;
        }
        .getty.alignright > div {
            float: right;
            margin-left: 5px;
        }
        </style>
        <script>var ms_grabbing_curosr = 'https://www.theedgesusu.co.uk/wp-content/plugins/master-slider/public/assets/css/common/grabbing.cur', ms_grab_curosr = 'https://www.theedgesusu.co.uk/wp-content/plugins/master-slider/public/assets/css/common/grab.cur';</script>
<meta name="generator" content="MasterSlider 3.6.5 - Responsive Touch Image Slider | avt.li/msf" />
			<style type="text/css">
				 
			.wp-night-mode-slider {
				background-color: ;
			}

			.wp-night-mode-button.active .wp-night-mode-slider {
				background-color: ;
			}

			body.wp-night-mode-on * {
				background: #2d2d2d;
			}

			body.wp-night-mode-on .customize-partial-edit-shortcut button,
			body.wp-night-mode-on .customize-partial-edit-shortcut button svg,
			body.wp-night-mode-on #adminbarsearch,
			body.wp-night-mode-on span.display-name,
			body.wp-night-mode-on span.ab-icon,
			body.wp-night-mode-on span.ab-label {
			    background: transparent;
			}

			body.wp-night-mode-on * {
				color: #ffffff;
			}

			body.wp-night-mode-on a {
				color: #ffffff;
			}

			body.wp-night-mode-on a:hover,
			body.wp-night-mode-on a:visited,
			body.wp-night-mode-on a:active {
				color: #ffffff;
			}
		}				@media (prefers-color-scheme: dark) {
					 
			.wp-night-mode-slider {
				background-color: ;
			}

			.wp-night-mode-button.active .wp-night-mode-slider {
				background-color: ;
			}

			body.wp-night-mode-on * {
				background: #2d2d2d;
			}

			body.wp-night-mode-on .customize-partial-edit-shortcut button,
			body.wp-night-mode-on .customize-partial-edit-shortcut button svg,
			body.wp-night-mode-on #adminbarsearch,
			body.wp-night-mode-on span.display-name,
			body.wp-night-mode-on span.ab-icon,
			body.wp-night-mode-on span.ab-label {
			    background: transparent;
			}

			body.wp-night-mode-on * {
				color: #ffffff;
			}

			body.wp-night-mode-on a {
				color: #ffffff;
			}

			body.wp-night-mode-on a:hover,
			body.wp-night-mode-on a:visited,
			body.wp-night-mode-on a:active {
				color: #ffffff;
			}
		}				}
			</style>
		<style type='text/css'>img#wpstats{display:none}</style>
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;" />
<meta property="og:url" content="https://www.theedgesusu.co.uk/records/albums/2020/12/22/lacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird/" />
<meta property="og:description" content="Charlotte Brennan discusses the latest album from pop-rocker Yungblud." />
<meta property="article:published_time" content="2020-12-22T12:00:48+00:00" />
<meta property="article:modified_time" content="2020-12-21T19:35:58+00:00" />
<meta property="og:site_name" content="The Edge" />
<meta property="og:image" content="https://www.theedgesusu.co.uk/wp-content/uploads/2020/12/Webp.net-resizeimage.jpg" />
<meta property="og:image:width" content="702" />
<meta property="og:image:height" content="336" />
<meta property="og:locale" content="en_GB" />
<meta name="twitter:text:title" content="Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;" />
<meta name="twitter:image" content="https://www.theedgesusu.co.uk/wp-content/uploads/2020/12/Webp.net-resizeimage.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://www.theedgesusu.co.uk/wp-content/uploads/2020/02/cropped-edge-logo-32x32.gif" sizes="32x32" />
<link rel="icon" href="https://www.theedgesusu.co.uk/wp-content/uploads/2020/02/cropped-edge-logo-192x192.gif" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.theedgesusu.co.uk/wp-content/uploads/2020/02/cropped-edge-logo-180x180.gif" />
<meta name="msapplication-TileImage" content="https://www.theedgesusu.co.uk/wp-content/uploads/2020/02/cropped-edge-logo-270x270.gif" />
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://www.theedgesusu.co.uk/?custom-css=1646f8fde0" />
			
<!--[if lt IE 9]>
<script src="https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/js/html5.js" type="text/javascript"></script>
<![endif]-->
</head>

<body class="post-template-default single single-post postid-166654 single-format-standard page-builder _masterslider _ms_version_3.6.5 right-sidebar full">
<div class="main-wrap">

	
	
	<div class="top-bar">

		<div class="wrap">
			<section class="top-bar-content">
			
								<div class="trending-ticker">
					<span class="heading">Read more</span>

					<ul>
												
												
							<li><a href="https://www.theedgesusu.co.uk/records/albums/2020/12/22/lacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird/" title="Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;">Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/culture/2020/12/22/one-day-at-a-time-socially-relevant-unjustly-cancelled/" title="One Day At A Time: Socially Relevant, Unjustly Cancelled">One Day At A Time: Socially Relevant, Unjustly Cancelled</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/records/albums/2020/12/20/a-dreary-crawl-a-review-of-chris-kamaras-and-a-happy-new-year/" title="A &#8216;Dreary Crawl&#8217;: A Review of Chris Kamara&#8217;s &#8230;And A Happy New Year">A &#8216;Dreary Crawl&#8217;: A Review of Chris Kamara&#8217;s &#8230;And A Happy New Year</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/culture/2020/12/20/hidden-gem-spinning-out-series-1/" title="Hidden Gem: Spinning Out (Series 1)">Hidden Gem: Spinning Out (Series 1)</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/news/2020/12/19/disney-announces-obi-wan-kenobi-show/" title="Disney Announces Obi-wan Kenobi Show">Disney Announces Obi-wan Kenobi Show</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/live/reviews/2020/12/18/review-sean-mcgowan-at-the-1865-southampton/" title="Review: Sean McGowan at The 1865, Southampton">Review: Sean McGowan at The 1865, Southampton</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/news/2020/12/18/justin-bieber-teams-up-with-nhs-choir-in-race-to-christmas-no-1/" title="Justin Bieber Teams Up with NHS Choir in Race to Christmas No. 1">Justin Bieber Teams Up with NHS Choir in Race to Christmas No. 1</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/records/albums/2020/12/18/deep-and-compelling-indie-fun-a-review-of-will-joseph-cooks-something-to-feel-good-about/" title="Deep and Compelling Indie Fun: A Review of Will Joseph Cook&#8217;s Something to Feel Good About">Deep and Compelling Indie Fun: A Review of Will Joseph Cook&#8217;s Something to Feel Good About</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/news/2020/12/17/nostalgic-news-black-swan-was-released-10-years-ago/" title="Nostalgic News: Black Swan was released 10 years ago">Nostalgic News: Black Swan was released 10 years ago</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/culture/2020/12/17/vinand-saga-bloodthirsty-modern-day-epic/" title="Vinland Saga: Bloodthirsty Modern-Day Epic">Vinland Saga: Bloodthirsty Modern-Day Epic</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/news/2020/12/16/nostalgic-news-heat-was-released-25-years-ago-16-12/" title="Nostalgic News: Heat was released 25 years ago">Nostalgic News: Heat was released 25 years ago</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/records/2020/12/16/the-recipe-for-the-perfect-christmas-song/" title="The Recipe for the Perfect Christmas Song">The Recipe for the Perfect Christmas Song</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/news/2020/12/15/nostalgic-news-the-emperors-new-groove-was-released-20-years-ago/" title="Nostalgic News: The Emperor&#8217;s New Groove was released 20 years ago">Nostalgic News: The Emperor&#8217;s New Groove was released 20 years ago</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/film/2020/12/15/actor-in-focus-steven-yeun/" title="Actor in Focus: Steven Yeun">Actor in Focus: Steven Yeun</a></li>
						
												
											</ul>
				</div>
				
				
				<div class="search">
					<form role="search" action="https://www.theedgesusu.co.uk/" method="get">
						<input type="text" name="s" class="query" value="" placeholder="Search..." />
						<button class="search-button" type="submit"><i class="fa fa-search"></i></button>
					</form>
				</div> <!-- .search -->
								
			</section>
		</div>
		
	</div>
	
	
	<div id="main-head" class="main-head">
		
		<div class="wrap">
		
			<header>
				<div class="title">
				
				<a href="https://www.theedgesusu.co.uk/" title="The Edge" rel="home">
									
					<img src="https://www.theedgesusu.co.uk/wp-content/uploads/2017/07/The-Edge-Logo_Black-e1498892715797.png" class="logo-image" alt="The Edge" data-at2x="https://www.theedgesusu.co.uk/wp-content/uploads/2017/07/The-Edge-Logo_Black-e1498892715797.png" />
						 
								</a>
				
				</div>
				
				<div class="right">
								<div class="textwidget"><div id="fblike" class="fb-like" data-href="https://www.facebook.com/theedgesusu" data-layout="standard" data-action="like" data-show-faces="false" data-share="false">
</div> <br>


<p style="text-align:left; line-height: 1.1;">The University of Southampton's entertainment magazine.</p>


</div>
						</div>
			</header>
			
						
			<nav class="navigation cf" data-sticky-nav="1">
			
				<div class="mobile" data-type="classic" data-search="1">
					<a href="#" class="selected">
						<span class="text">Navigate</span><span class="current"></span> <i class="hamburger fa fa-bars"></i>
					</a>
				</div>
				
				<div class="menu-menu-thea-edition-container"><ul id="menu-menu-thea-edition" class="menu"><li id="menu-item-137518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-137518"><a href="https://www.theedgesusu.co.uk/">Home</a></li>
<li id="menu-item-137539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-6543 menu-item-137539"><a href="https://www.theedgesusu.co.uk/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-159161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-25970 menu-item-159161"><a href="https://www.theedgesusu.co.uk/category/news/local-news/">Local News</a></li>
	<li id="menu-item-159160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-25969 menu-item-159160"><a href="https://www.theedgesusu.co.uk/category/news/global-news/">Global News</a></li>
	<li id="menu-item-163151" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-26590 menu-item-163151"><a href="https://www.theedgesusu.co.uk/category/news/nostalgic-news/">Nostalgic News</a></li>
	<li id="menu-item-159182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-25971 menu-item-159182"><a href="https://www.theedgesusu.co.uk/category/news/wekkly-roundups-news/">Weekly Roundups</a></li>
</ul>
</li>
<li id="menu-item-137522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-9 menu-item-137522"><a href="https://www.theedgesusu.co.uk/category/culture/">Culture</a>
<ul class="sub-menu">
	<li id="menu-item-137523" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22362 menu-item-137523"><a href="https://www.theedgesusu.co.uk/category/culture/features-culture/">Features</a></li>
	<li id="menu-item-137524" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22368 menu-item-137524"><a href="https://www.theedgesusu.co.uk/category/culture/interviews-culture/">Interviews</a></li>
	<li id="menu-item-137526" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-47 menu-item-137526"><a href="https://www.theedgesusu.co.uk/category/culture/television/">Television</a></li>
	<li id="menu-item-137528" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-283 menu-item-137528"><a href="https://www.theedgesusu.co.uk/category/culture/video-games/">Video Games</a></li>
	<li id="menu-item-137525" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-446 menu-item-137525"><a href="https://www.theedgesusu.co.uk/category/culture/literature/">Literature</a></li>
	<li id="menu-item-146907" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-24524 menu-item-146907"><a href="https://www.theedgesusu.co.uk/category/culture/art/">Art</a></li>
	<li id="menu-item-137527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-471 menu-item-137527"><a href="https://www.theedgesusu.co.uk/category/culture/theatre/">Theatre</a></li>
	<li id="menu-item-159159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-26042 menu-item-159159"><a href="https://www.theedgesusu.co.uk/category/culture/podcasts/">Podcasts</a></li>
</ul>
</li>
<li id="menu-item-137529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-6544 menu-item-137529"><a href="https://www.theedgesusu.co.uk/category/film/">Film</a>
<ul class="sub-menu">
	<li id="menu-item-137532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22366 menu-item-137532"><a href="https://www.theedgesusu.co.uk/category/film/features-film/">Features</a></li>
	<li id="menu-item-137533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22367 menu-item-137533"><a href="https://www.theedgesusu.co.uk/category/film/interviews-film/">Interviews</a></li>
	<li id="menu-item-137530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-442 menu-item-137530"><a href="https://www.theedgesusu.co.uk/category/film/cinema/">Cinema</a></li>
	<li id="menu-item-137531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-65 menu-item-137531"><a href="https://www.theedgesusu.co.uk/category/film/dvd-bluray/">DVD &amp; Blu-Ray</a></li>
</ul>
</li>
<li id="menu-item-137534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-6545 menu-item-137534"><a href="https://www.theedgesusu.co.uk/category/live/">Live</a>
<ul class="sub-menu">
	<li id="menu-item-137535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22365 menu-item-137535"><a href="https://www.theedgesusu.co.uk/category/live/features-live/">Features</a></li>
	<li id="menu-item-137537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22369 menu-item-137537"><a href="https://www.theedgesusu.co.uk/category/live/interviews-live/">Interviews</a></li>
	<li id="menu-item-137538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-19 menu-item-137538"><a href="https://www.theedgesusu.co.uk/category/live/reviews/">Reviews</a></li>
	<li id="menu-item-137536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-10397 menu-item-137536"><a href="https://www.theedgesusu.co.uk/category/live/festivals/">Festivals</a></li>
	<li id="menu-item-146906" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-24513 menu-item-146906"><a href="https://www.theedgesusu.co.uk/category/live/dance/">Dance</a></li>
</ul>
</li>
<li id="menu-item-137540" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-cat-5884 menu-item-137540"><a href="https://www.theedgesusu.co.uk/category/records/">Records</a>
<ul class="sub-menu">
	<li id="menu-item-137542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22364 menu-item-137542"><a href="https://www.theedgesusu.co.uk/category/records/features-records/">Features</a></li>
	<li id="menu-item-137543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22370 menu-item-137543"><a href="https://www.theedgesusu.co.uk/category/records/interviews-records/">Interviews</a></li>
	<li id="menu-item-137541" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-17 menu-item-137541"><a href="https://www.theedgesusu.co.uk/category/records/albums/">Albums</a></li>
	<li id="menu-item-137544" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-15 menu-item-137544"><a href="https://www.theedgesusu.co.uk/category/records/singles/">Singles</a></li>
</ul>
</li>
<li id="menu-item-137519" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-137519"><a href="https://www.theedgesusu.co.uk/contact-us/">Contact Us</a>
<ul class="sub-menu">
	<li id="menu-item-137521" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137521"><a href="https://www.theedgesusu.co.uk/getting-started-writing-for-the-edge/">Join Us</a></li>
	<li id="menu-item-137520" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137520"><a href="https://www.theedgesusu.co.uk/contact-us/committee-details/">Meet the Committee</a></li>
</ul>
</li>
<li id="menu-item-159716" class="wp-night-mode menu-item menu-item-type-custom menu-item-object-custom menu-item-159716"><a href="#">Night Mode</a></li>
</ul></div>			</nav>
			
		</div>
		
	</div>
	
	<div class="wrap">
		<div class="breadcrumbs"><span class="location">You are at:</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.theedgesusu.co.uk/"><span itemprop="title">Home</span></a></span><span class="delim">&raquo;</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url"  href="https://www.theedgesusu.co.uk/category/records/"><span itemprop="title">Records</span></a></span><span class="delim">&raquo;</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url"  href="https://www.theedgesusu.co.uk/category/records/albums/"><span itemprop="title">Albums</span></a></span><span class="delim">&raquo;</span><span class="current">Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;</span></div>	</div>


<div class="main wrap cf">
	<div class="row">
		<div class="col-8 main-content">
		
			
				
<article id="post-166654" class="hreview post-166654 post type-post status-publish format-standard has-post-thumbnail category-albums category-records tag-album tag-music tag-pop tag-records tag-review tag-rock tag-weird tag-yungblud" itemscope itemtype="http://schema.org/Article">
	
	<header class="post-header cf">

			<div class="featured">
						
				<a href="https://www.theedgesusu.co.uk/wp-content/uploads/2020/12/Webp.net-resizeimage.jpg" title="Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;" itemprop="image">
				
								
										
						<img width="702" height="336" src="https://www.theedgesusu.co.uk/wp-content/uploads/2020/12/Webp.net-resizeimage-702x336.jpg" class="attachment-main-slider size-main-slider wp-post-image" alt="" title="Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;" srcset="https://www.theedgesusu.co.uk/wp-content/uploads/2020/12/Webp.net-resizeimage.jpg 702w, https://www.theedgesusu.co.uk/wp-content/uploads/2020/12/Webp.net-resizeimage-300x144.jpg 300w, https://www.theedgesusu.co.uk/wp-content/uploads/2020/12/Webp.net-resizeimage-300x144@2x.jpg 600w" sizes="(max-width: 702px) 100vw, 702px" />					
										
								
				</a>
								
										
					<div class="caption">via Interscope Records</div>
						
								
					</div>
	
		
		<h1 class="post-title" itemprop="name">
		Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;		</h1>
		
		<a href="https://www.theedgesusu.co.uk/records/albums/2020/12/22/lacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird/#respond" class="comments"><i class="fa fa-comments-o"></i> 0</a>
		
	</header><!-- .post-header -->
	
	<div class="post-meta">
		<span class="posted-by">By 
			<span class="reviewer test123" itemprop="author">

				Charlotte Brennan			</span>
		</span>
		 
		<span class="posted-on">on			<span class="dtreviewed">
				<time class="value-datetime" datetime="2020-12-22T12:00:48+00:00" itemprop="datePublished">December 22, 2020</time>
			</span>
		</span>
		
		<span class="cats"><a href="https://www.theedgesusu.co.uk/category/records/albums/" rel="category tag">Albums</a>, <a href="https://www.theedgesusu.co.uk/category/records/" rel="category tag">Records</a></span>
			
	</div>
	

	<div class="post-container cf">
	
		<div class="post-content-right">
			<div class="post-content description " itemprop="articleBody">
			
				
								
				
<section class="review-box stars">
		
	
	<div class="verdict-box">
		<div class="overall">
			<span class="number rating"><span class="value">55<span class="percent">%</span></span>
				
								<div class="overall-stars">
					<div class="main-stars">
						<span style="width: 55%;"><strong class="rating">55</strong></span>
					</div>
				</div>
				
								
				<span class="best"><span class="value-title" title="10"></span></span>
			</span>
			<span class="verdict">A Rollercoaster of a Record</span>
		</div>
		
		<div class="text summary"><p>YUNGBLUD gets weird on his latest album, taking on various different styles throughout the record.</p>
</div>		
	</div>
	
	
	<ul>
		
		<li>
		
				
			<div class="criterion">
				<span class="label"></span>

				<div class="main-stars">
					<span style="width: 55%;"><strong class="rating">5.5</strong></span>
				</div>
			
			</div>
				
		
		</li>
	
		
		
	</ul>
</section><p>Everyone’s favourite modern punk rocker <a href="/tag/yungblud">YUNGBLUD</a> is back with his sophomore album <em>weird!</em> and this rollercoaster of a record is one you certainly don’t want to miss. The Doncaster-born rock star’s first album <a href="https://www.theedgesusu.co.uk/records/albums/2018/07/19/review-yungblud-21st-century-liability/"><em>21<sup>st</sup> Century Liability</em></a> released in 2018 was a blend of hip-hop and rock that allowed Dominic Harrison to let everyone know how angry and frustrated he was with the world. On this new batch of songs Dom takes his inspiration from the stories of his passionate fan base and uses his voice to inject a feeling of unity and love into a generation that has seemingly had enough. Although this record has lost some of the rebellious energy that contributed to Harrison’s appeal as an artist, <em>weird!</em> is still an enjoyable listen and the majority of tracks will find a way into your playlists.</p>
<p>Opening with the haunting ballad ‘teresa’, we are hit straight away with the bold lyrics “As long as I watch over you, you don’t need to run”. This gloomy, dark rock song incorporates sounds from multiple iconic musicians like <a href="/tag/queen">Queen</a> and <a href="/tag/my-chemical-romance">My Chemical Romance</a> and is so striking sonically. YUNGBLUD likes to wear his influences on his sleeve and on this song, in particular, that is done tastefully. Although it sounds completely different from anything we have heard from Harrison before, his snarly delivery and passionate vocals on this ballad sound fantastic and as an album opener, it is a 10/10.</p>
<p>‘cotton candy’, which sounds just as sugary sweet as its name, comes next in the tracklist. This light and fun song about sex and sexuality is a huge contrast in sound and vibe to ‘teresa’ but is still getting an important message across. Especially when paired with the bright, raunchy visuals of the music video, ‘cotton candy’ celebrates all kinds of gender expression and sexual liberation which is a message YUNGBLUD is passionate about. This is certainly apparent in his choice of outfits and the fact that he is unafraid to publically wear skirts and makeup. The funky bassline makes this upbeat tune so fun to listen to and makes it a song that you can just throw on no matter what to dance around to and just feel good about yourself.</p>
<p>Out of every song on the album ‘mars’ is definitely the most important track and the one that everyone needs to hear. The song is inspired by the story of a transgender girl that Harrison met at one of his shows. The girl’s parents weren’t accepting of her gender, but she brought her parents to his performance and with the impact and support of the community, her parents started to accept her as their daughter. The lyrics “Yeah, her Mum and Dad, they couldn’t understand Why she couldn’t turn it off, become a better man” are really striking and hit home how the fight that many people have to be accepted for who they are. This emotional acoustic number is easily the best song on the album and will be an anthem not just for the trans community but for anyone who feels misunderstood.</p>
<p>Although most of the songs on the album are interesting enough to listen to, the further you get into the album the more lackluster the songs become. ‘ice cream man’ is sickeningly sweet and is one of YUNGBLUD’s worst songs to date. It is both bouncy and catchy but after repeated listens it becomes increasingly irritating and one of the songs on the album that you automatically go to skip as soon as you hear the twinkling sound of an ice cream van siren play. ‘charity’ is another song that could be axed from the tracklist to make the album sound so much better. Attempting to sound like a cross between the streets and blur Harrison’s delivery comes across as a bit cringey even though the meaning of the song is wholesome and genuine.</p>
<p>The final song on the album is worth waiting for! ‘the freak show’ is a phenomenal track and is reminiscent of the theatrical style present on <a href="/tag/panic!-at-the-disco">Panic! At The Disco</a>’s debut album <em>A Fever You Can’t Sweat Out </em>(2005). When talking about the song YUNGBLUD has said: “I wanted a ‘Bohemian Rhapsody.’ There are four key changes, five time changes, and a big, dramatic ending. It’s every YUNGBLUD song squeezed into one”. The song sounds massive and the chorus, in particular, is so dramatic, bold and powerful. As the song comes to a close Dom finishes with the line “Times will change And you might break But I will spend my life believing in you!”. This line is a direct message to his fans and in an interview with NME he has disclosed that the album is for and about his fans and that “these are your [his fans]words that I’ve just put to music”. This track is the perfect way to end the record and will be one of the most exciting YUNGBLUD songs to see performed live.</p>
<p><em>Weird!</em> is certainly not a perfect body of work and at times can be quite annoying and too sugary sweet, however, the messages behind each song make the album so much more personal. The mesh of different genres turns the record into a rollercoaster of a journey during the 42-minute runtime and can at times be quite unsettling but, when listening to the songs in isolation, Harrison does nail the majority of these different styles. Overall, the songs sound great for the most part and this project is worth giving some time to. It is a lot more mature in sound than <em>21<sup>st</sup> Century Liability</em> and is likely to appeal to a wider audience making it a step in the right direction for YUNGBLUD in his musical career.</p>
<p><strong>weird! is available now via Interscope Records. Check out the music video for &#8216;Cotton Candy&#8217; below.</strong></p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='702' height='395' src='https://www.youtube.com/embed/yDeIAllUAWc?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-GB&#038;autohide=2&#038;wmode=transparent' allowfullscreen='true' style='border:0;' sandbox='allow-scripts allow-same-origin allow-popups allow-presentation'></iframe></span></p>

				
								
							</div><!-- .post-content -->
		</div>
		
	</div>
	
	
		
	<div class="post-share">
		<span class="text">Share.</span>
		
		<span class="share-links">

			<a href="http://twitter.com/home?status=https%3A%2F%2Fwww.theedgesusu.co.uk%2Frecords%2Falbums%2F2020%2F12%2F22%2Flacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird%2F" class="fa fa-twitter" title="Tweet It">
				<span class="visuallyhidden">Twitter</span></a>
				
			<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theedgesusu.co.uk%2Frecords%2Falbums%2F2020%2F12%2F22%2Flacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird%2F" class="fa fa-facebook" title="Share on Facebook">
				<span class="visuallyhidden">Facebook</span></a>
				
			<a href="http://plus.google.com/share?url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Frecords%2Falbums%2F2020%2F12%2F22%2Flacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird%2F" class="fa fa-google-plus" title="Share on Google+">
				<span class="visuallyhidden">Google+</span></a>
				
			<a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Frecords%2Falbums%2F2020%2F12%2F22%2Flacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird%2F&amp;media=https%3A%2F%2Fwww.theedgesusu.co.uk%2Fwp-content%2Fuploads%2F2020%2F12%2FWebp.net-resizeimage.jpg" class="fa fa-pinterest"
				title="Share on Pinterest">
				<span class="visuallyhidden">Pinterest</span></a>
				
			<a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Frecords%2Falbums%2F2020%2F12%2F22%2Flacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird%2F" class="fa fa-linkedin" title="Share on LinkedIn">
				<span class="visuallyhidden">LinkedIn</span></a>
				
			<a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Frecords%2Falbums%2F2020%2F12%2F22%2Flacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird%2F&amp;name=Lacking+Rebellion%2C+Yet+Still+Showing+That+Much-Loved+Excitement%3A+A+Review+of+YUNGBLUD%26%238217%3Bs+%26%238216%3Bweird%21%26%238217%3B" class="fa fa-tumblr"
				title="Share on Tumblr">
				<span class="visuallyhidden">Tumblr</span></a>
				
			<a href="mailto:?subject=Lacking%20Rebellion%2C%20Yet%20Still%20Showing%20That%20Much-Loved%20Excitement%3A%20A%20Review%20of%20YUNGBLUD%26%238217%3Bs%20%26%238216%3Bweird%21%26%238217%3B&amp;body=https%3A%2F%2Fwww.theedgesusu.co.uk%2Frecords%2Falbums%2F2020%2F12%2F22%2Flacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird%2F" class="fa fa-envelope-o"
				title="Share via Email">
				<span class="visuallyhidden">Email</span></a>
			
		</span>
	</div>
	
			
</article>




	<h3 class="section-head">About Author</h3>

	            <section class="author-info">
            
                <img src='/avatars/5199b7bb-0863-4836-8f16-dbd3fbd12407-cropped.png' class='avatar avatar-100 avatar-default' height='100' width='100' style='width: 100px; height: 100px;' alt='avatar' />                
                <div class="description"> 
                    <a href="https://www.theedgesusu.co.uk/author/charlotte-brennan/" title="Posts by Charlotte Brennan" rel="author">Charlotte Brennan</a>
 
                    <ul class="social-icons">
                                        </ul>
                                        <p class="bio">A Second Year English student with a love for all things music</p>
                </div>
                
            </section>



<section class="related-posts">
	<h3 class="section-head">Related Posts</h3> 
	<ul class="highlights-box three-col related-posts">
	
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="https://www.theedgesusu.co.uk/records/albums/2020/12/20/a-dreary-crawl-a-review-of-chris-kamaras-and-a-happy-new-year/" title="A &#8216;Dreary Crawl&#8217;: A Review of Chris Kamara&#8217;s &#8230;And A Happy New Year" class="image-link">
					<img width="214" height="140" src="https://www.theedgesusu.co.uk/wp-content/uploads/2020/12/Kammy-214x140.jpg" class="image wp-post-image" alt="" title="A &#8216;Dreary Crawl&#8217;: A Review of Chris Kamara&#8217;s &#8230;And A Happy New Year" />
									</a>
				
				<div class="meta">
					<time datetime="2020-12-20T11:00:09+00:00">December 20, 2020 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="https://www.theedgesusu.co.uk/records/albums/2020/12/20/a-dreary-crawl-a-review-of-chris-kamaras-and-a-happy-new-year/" title="A &#8216;Dreary Crawl&#8217;: A Review of Chris Kamara&#8217;s &#8230;And A Happy New Year">A &#8216;Dreary Crawl&#8217;: A Review of Chris Kamara&#8217;s &#8230;And A Happy New Year</a></h2>
				
			</article>
		</li>
		
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="https://www.theedgesusu.co.uk/records/albums/2020/12/18/deep-and-compelling-indie-fun-a-review-of-will-joseph-cooks-something-to-feel-good-about/" title="Deep and Compelling Indie Fun: A Review of Will Joseph Cook&#8217;s Something to Feel Good About" class="image-link">
					<img width="214" height="140" src="https://www.theedgesusu.co.uk/wp-content/uploads/2017/02/Will-Joseph-Cook-1-e1488042436563-214x140.jpg" class="image wp-post-image" alt="" title="Deep and Compelling Indie Fun: A Review of Will Joseph Cook&#8217;s Something to Feel Good About" />
									</a>
				
				<div class="meta">
					<time datetime="2020-12-18T11:00:24+00:00">December 18, 2020 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="https://www.theedgesusu.co.uk/records/albums/2020/12/18/deep-and-compelling-indie-fun-a-review-of-will-joseph-cooks-something-to-feel-good-about/" title="Deep and Compelling Indie Fun: A Review of Will Joseph Cook&#8217;s Something to Feel Good About">Deep and Compelling Indie Fun: A Review of Will Joseph Cook&#8217;s Something to Feel Good About</a></h2>
				
			</article>
		</li>
		
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="https://www.theedgesusu.co.uk/records/2020/12/16/the-recipe-for-the-perfect-christmas-song/" title="The Recipe for the Perfect Christmas Song" class="image-link">
					<img width="214" height="140" src="https://www.theedgesusu.co.uk/wp-content/uploads/2020/12/RECIPE-CHRISTMAS-214x140.jpg" class="image wp-post-image" alt="" title="The Recipe for the Perfect Christmas Song" />
									</a>
				
				<div class="meta">
					<time datetime="2020-12-16T11:00:54+00:00">December 16, 2020 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="https://www.theedgesusu.co.uk/records/2020/12/16/the-recipe-for-the-perfect-christmas-song/" title="The Recipe for the Perfect Christmas Song">The Recipe for the Perfect Christmas Song</a></h2>
				
			</article>
		</li>
		
		</ul>
</section>

				<div class="comments">
				
	
	<div id="comments">

		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span class="section-head">Leave A Reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/records/albums/2020/12/22/lacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://www.theedgesusu.co.uk/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
			<p>
				<textarea name="comment" id="comment" cols="45" rows="8" aria-required="true" placeholder="Your Comment"></textarea>
			</p>
				<p>
					<input name="author" id="author" type="text" value="" size="30" aria-required="true" placeholder="Your Name" />
				</p>

				<p>
					<input name="email" id="email" type="text" value="" size="30" aria-required="true" placeholder="Your Email" />
				</p>
			

				<p>
					<input name="url" id="url" type="text" value="" size="30" placeholder="Your Website" />
				</p>
			
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='166654' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="bca015b265" /></p>
<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf1N='d4cc3ffda730202929fdb0f4908787fd';
hf1V='49b1ea26f1609ee6352650459bcac69b';
document.write("<input type='hidden' name='r3f5x9JS' value='"+r3f5x9JS+"' /><input type='hidden' name='"+hf1N+"' value='"+hf1V+"' />");
/* ]]> */
</script>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="66"/></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
				</div>

			
		</div>

		
			
		
		<aside class="col-4 sidebar">
			<ul>
			
			<li id="wpcom_social_media_icons_widget-3" class="widget widget_wpcom_social_media_icons_widget"><h3 class="widgettitle">Find us on Social Media!</h3><ul><li><a href="https://www.facebook.com/theedgesusu/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View theedgesusu&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/theedgesusu/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View theedgesusu&#8217;s profile on Twitter</span></a></li><li><a href="https://www.instagram.com/theedgesusu/" class="genericon genericon-instagram" target="_blank"><span class="screen-reader-text">View theedgesusu&#8217;s profile on Instagram</span></a></li><li><a href="https://www.twitch.tv/the_edge_susu/" class="genericon genericon-twitch" target="_blank"><span class="screen-reader-text">View the_edge_susu&#8217;s profile on Twitch</span></a></li></ul></li>
<li id="text-11" class="widget widget_text"><h3 class="widgettitle">Read our latest issue here:</h3>			<div class="textwidget"><div style="height: 420px;"><iframe src="https://drive.google.com/file/d/1vpLlWLcr4t-ubdNIb1ah6eDHXoShMMOU/preview" height="100%"></iframe></div>
<p><!-- just replace the link in the speech marks after src= with the latest edition's google drive link, with the /preview on the end. e.g a link like this one https://drive.google.com/file/d/1JKADLRREHF4Kw9KbojeFso8UjCPcxPbU/preview --></p>
</div>
		</li>
<li id="text-13" class="widget widget_text"><h3 class="widgettitle">Read our collaborative issue here:</h3>			<div class="textwidget"><div style="height: 420px;"><iframe src="https://drive.google.com/file/d/18TGpLpJPHw3YW7DmGLd8B8Y4KOvZE_Ol/preview" height="100%"></iframe></div>
<p><!-- just replace the link in the speech marks after src= with the latest edition's google drive link, with the /preview on the end. e.g a link like this one https://drive.google.com/file/d/1JKADLRREHF4Kw9KbojeFso8UjCPcxPbU/preview --></p>
</div>
		</li>
<li id="text-9" class="widget widget_text"><h3 class="widgettitle">Check Out What We&#8217;re Listening To:</h3>			<div class="textwidget"><p><iframe title="Spotify Embed: What We&#039;re Listening To: OCTOBER 2020" allowtransparency="true" frameborder="0" allow="encrypted-media" src="https://open.spotify.com/embed/playlist/1LBbXDBgIiyeTDATtBtNMr"></iframe></p>
<p><iframe src="https://anchor.fm/the-edge4/embed/episodes/Tenet-ejr9bg" frameborder="0" scrolling="no"></iframe></p>
</div>
		</li>

			<li id="bunyad-latest-posts-widget-2" class="widget latest-posts">			
							<h3 class="widgettitle">Recent Posts</h3>						
			<ul class="posts-list">
			
							<li>
				
					<a href="https://www.theedgesusu.co.uk/records/albums/2020/12/22/lacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird/"><img width="110" height="96" src="https://www.theedgesusu.co.uk/wp-content/uploads/2020/12/Webp.net-resizeimage-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;" />					
										
					</a>
					
					<div class="content">
					
						<time datetime="2020-12-22T12:00:48+00:00">December 22, 2020 </time>
					
						<span class="comments"><a href="https://www.theedgesusu.co.uk/records/albums/2020/12/22/lacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="https://www.theedgesusu.co.uk/records/albums/2020/12/22/lacking-rebellion-yet-still-showing-that-much-loved-excitement-a-review-of-yungbluds-weird/" title="Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;">
							Lacking Rebellion, Yet Still Showing That Much-Loved Excitement: A Review of YUNGBLUD&#8217;s &#8216;weird!&#8217;</a>
							
																							
					</div>
				
				</li>
							<li>
				
					<a href="https://www.theedgesusu.co.uk/culture/2020/12/22/one-day-at-a-time-socially-relevant-unjustly-cancelled/"><img width="110" height="96" src="https://www.theedgesusu.co.uk/wp-content/uploads/2020/05/ODAAT-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="One Day At A Time: Socially Relevant, Unjustly Cancelled" />					
										
					</a>
					
					<div class="content">
					
						<time datetime="2020-12-22T11:00:46+00:00">December 22, 2020 </time>
					
						<span class="comments"><a href="https://www.theedgesusu.co.uk/culture/2020/12/22/one-day-at-a-time-socially-relevant-unjustly-cancelled/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="https://www.theedgesusu.co.uk/culture/2020/12/22/one-day-at-a-time-socially-relevant-unjustly-cancelled/" title="One Day At A Time: Socially Relevant, Unjustly Cancelled">
							One Day At A Time: Socially Relevant, Unjustly Cancelled</a>
							
																							
					</div>
				
				</li>
							<li>
				
					<a href="https://www.theedgesusu.co.uk/records/albums/2020/12/20/a-dreary-crawl-a-review-of-chris-kamaras-and-a-happy-new-year/"><img width="110" height="96" src="https://www.theedgesusu.co.uk/wp-content/uploads/2020/12/Kammy-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="A &#8216;Dreary Crawl&#8217;: A Review of Chris Kamara&#8217;s &#8230;And A Happy New Year" />					
										
					</a>
					
					<div class="content">
					
						<time datetime="2020-12-20T11:00:09+00:00">December 20, 2020 </time>
					
						<span class="comments"><a href="https://www.theedgesusu.co.uk/records/albums/2020/12/20/a-dreary-crawl-a-review-of-chris-kamaras-and-a-happy-new-year/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="https://www.theedgesusu.co.uk/records/albums/2020/12/20/a-dreary-crawl-a-review-of-chris-kamaras-and-a-happy-new-year/" title="A &#8216;Dreary Crawl&#8217;: A Review of Chris Kamara&#8217;s &#8230;And A Happy New Year">
							A &#8216;Dreary Crawl&#8217;: A Review of Chris Kamara&#8217;s &#8230;And A Happy New Year</a>
							
																							
					</div>
				
				</li>
						</ul>
			
			</li>
	
			</ul>
		</aside>
		
			
	</div> <!-- .row -->
</div> <!-- .main -->

<div id='avatar_footer_credit' style='display: none;'>Avatars by <a href='http://www.sterling-adventures.co.uk/blog/'>Sterling Adventures</a></div>
		
	<footer class="main-footer">
	
		
	
			<div class="lower-foot">
			<div class="wrap">
		
						
			<div class="widgets">
				<div class="menu-footer-navigation-container"><ul id="menu-footer-navigation" class="menu"><li id="menu-item-106636" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-106636"><a href="https://docs.google.com/forms/d/e/1FAIpQLSdo5YmhvZyw-gS-MpbCBiQ1XxYcdD2AL1PfDdqvSvRbtkuEUw/viewform">Register/Forgot Password</a></li>
<li id="menu-item-57232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57232"><a href="http://www.theedgesusu.co.uk/wp-admin">Writer Login</a></li>
</ul></div>			</div>
			
					
			</div>
		</div>		
		
	</footer>
	
</div> <!-- .main-wrap -->


<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='d4cc3ffda730202929fdb0f4908787fd';
hf4V='49b1ea26f1609ee6352650459bcac69b';
cm4S="form[action='https://www.theedgesusu.co.uk/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form, .wpcf7-form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});});
/* ]]> */
</script> 
	<div style="display:none">
	<div class="grofile-hash-map-2de7ea9bca116ffea74870a192753d98">
	</div>
	</div>
<link rel='stylesheet' id='genericons-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/imgareaselect/jquery.imgareaselect.min.js?ver=5.6' id='imgareaselect-js'></script>
<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.theedgesusu.co.uk\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/comment-reply.min.js?ver=5.6' id='comment-reply-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.theedgesusu.co.uk\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.3.1' id='contact-form-7-js'></script>
<script type='text/javascript' id='bunyad-theme-js-extra'>
/* <![CDATA[ */
var Bunyad = {"ajaxurl":"https:\/\/www.theedgesusu.co.uk\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/js/bunyad-theme.js?ver=2.3.0' id='bunyad-theme-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/js/jquery.flexslider-min.js?ver=2.3.0' id='flex-slider-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/master-slider/public/assets/js/jquery.easing.min.js?ver=3.6.5' id='jquery-easing-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/master-slider/public/assets/js/masterslider.min.js?ver=3.6.5' id='masterslider-core-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/wp-spamshield/js/jscripts-ftr2-min.js' id='wpss-jscripts-ftr-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/wp-embed.min.js?ver=5.6' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/akismet/_inc/form.js?ver=4.1.7' id='akismet-form-js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202052.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.2.1',blog:'15861055',post:'166654',tz:'0',srv:'www.theedgesusu.co.uk'} ]);
	_stq.push([ 'clickTrackerInit', '15861055', '166654' ]);
</script>
</body>
</html>