<!DOCTYPE html>

<!--[if IE 8]> <html class="ie ie8" lang="en-GB"> <![endif]-->
<!--[if IE 9]> <html class="ie ie9" lang="en-GB"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-GB"> <!--<![endif]-->

<head>


<meta charset="UTF-8" />
<title>  Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;</title>

 
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="pingback" href="https://www.theedgesusu.co.uk/xmlrpc.php" />
	
<link rel="shortcut icon" href="https://www.theedgesusu.co.uk/wp-content/uploads/2014/11/favicon.png" />	

<link rel="apple-touch-icon-precomposed" href="https://www.theedgesusu.co.uk/wp-content/uploads/2015/03/mobile-icon.png" />
	
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Edge &raquo; Feed" href="https://www.theedgesusu.co.uk/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Edge &raquo; Comments Feed" href="https://www.theedgesusu.co.uk/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Edge &raquo; Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217; Comments Feed" href="https://www.theedgesusu.co.uk/film/2022/05/05/interview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.5.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-146182477-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.theedgesusu.co.uk\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='avatars-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/add-local-avatar/avatars.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='imgareaselect-css'  href='https://www.theedgesusu.co.uk/wp-includes/js/imgareaselect/imgareaselect.css?ver=0.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.theedgesusu.co.uk/wp-includes/css/dashicons.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.theedgesusu.co.uk/wp-includes/js/thickbox/thickbox.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.theedgesusu.co.uk/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://www.theedgesusu.co.uk/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.theedgesusu.co.uk/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp-night-mode-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/wp-night-mode/public/css/wp-night-mode-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400,600,700|Roboto+Slab' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-core-css'  href='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag-child/style.css?ver=2.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-responsive-css'  href='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/css/responsive.css?ver=2.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='pretty-photo-css'  href='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/css/prettyPhoto.css?ver=2.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-font-awesome-css'  href='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/css/fontawesome/css/font-awesome.min.css?ver=2.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='msl-main-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/master-slider/public/assets/css/masterslider.main.css?ver=3.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='msl-custom-css'  href='https://www.theedgesusu.co.uk/wp-content/uploads/master-slider/custom.css?ver=2.4' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-skin-css'  href='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/css/skin-light.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='custom-css-css'  href='https://www.theedgesusu.co.uk/?anchor_obj=6544&#038;bunyad_custom_css=1&#038;ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/jetpack/css/jetpack.css?ver=10.9' type='text/css' media='all' />
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<!--[if lt IE 8]>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/json2.min.js?ver=2015-05-03' id='json2-js'></script>
<![endif]-->
<script type='text/javascript' id='live-blogging-js-extra'>
/* <![CDATA[ */
var live_blogging = {"ajaxurl":"https:\/\/www.theedgesusu.co.uk\/wp-admin\/admin-ajax.php","update_effect":"top"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/live-blogging/live-blogging.min.js?ver=5.9.3' id='live-blogging-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.5.0' id='monsterinsights-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='monsterinsights-frontend-script-js-extra'>/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.theedgesusu.co.uk","hash_tracking":"false","ua":"UA-146182477-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' id='wp-night-mode-js-extra'>
/* <![CDATA[ */
var wpnmObject = {"button_html":"<div class=\"wpnm-button style-2\">\n                            <div class=\"wpnm-button-inner-left\"><\/div>\n                            <div class=\"wpnm-button-inner\"><\/div>\n                        <\/div>","default":"","server_time":"1651802479","turn_on_time":"","turn_off_time":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/wp-night-mode/public/js/wp-night-mode-public.js?ver=1.0.0' id='wp-night-mode-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/wp-retina-2x/app/picturefill.min.js?ver=1651666739' id='wr2x-picturefill-js-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/js/jquery.prettyPhoto.js?ver=5.9.3' id='pretty-photo-smartmag-js'></script>
<link rel="https://api.w.org/" href="https://www.theedgesusu.co.uk/wp-json/" /><link rel="alternate" type="application/json" href="https://www.theedgesusu.co.uk/wp-json/wp/v2/posts/175418" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.theedgesusu.co.uk/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.theedgesusu.co.uk/wp-includes/wlwmanifest.xml" /> 
<link rel="canonical" href="https://www.theedgesusu.co.uk/film/2022/05/05/interview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives/" />
<link rel='shortlink' href='https://wp.me/p14ybt-JDk' />
<link rel="alternate" type="application/json+oembed" href="https://www.theedgesusu.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Ffilm%2F2022%2F05%2F05%2Finterview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.theedgesusu.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Ffilm%2F2022%2F05%2F05%2Finterview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives%2F&#038;format=xml" />
        <style>
        .getty.aligncenter {
            text-align: center;
        }
        .getty.alignleft {
            float: none;
            margin-right: 0;
        }
        .getty.alignleft > div {
            float: left;
            margin-right: 5px;
        }
        .getty.alignright {
            float: none;
            margin-left: 0;
        }
        .getty.alignright > div {
            float: right;
            margin-left: 5px;
        }
        </style>
        <script>var ms_grabbing_curosr = 'https://www.theedgesusu.co.uk/wp-content/plugins/master-slider/public/assets/css/common/grabbing.cur', ms_grab_curosr = 'https://www.theedgesusu.co.uk/wp-content/plugins/master-slider/public/assets/css/common/grab.cur';</script>
<meta name="generator" content="MasterSlider 3.8.1 - Responsive Touch Image Slider | avt.li/msf" />
			<style type="text/css">
				 
			.wp-night-mode-slider {
				background-color: ;
			}

			.wp-night-mode-button.active .wp-night-mode-slider {
				background-color: ;
			}

			body.wp-night-mode-on * {
				background: #2d2d2d;
			}

			body.wp-night-mode-on .customize-partial-edit-shortcut button,
			body.wp-night-mode-on .customize-partial-edit-shortcut button svg,
			body.wp-night-mode-on #adminbarsearch,
			body.wp-night-mode-on span.display-name,
			body.wp-night-mode-on span.ab-icon,
			body.wp-night-mode-on span.ab-label {
			    background: transparent;
			}

			body.wp-night-mode-on * {
				color: #ffffff;
			}

			body.wp-night-mode-on a {
				color: #ffffff;
			}

			body.wp-night-mode-on a:hover,
			body.wp-night-mode-on a:visited,
			body.wp-night-mode-on a:active {
				color: #ffffff;
			}
		}				@media (prefers-color-scheme: dark) {
					 
			.wp-night-mode-slider {
				background-color: ;
			}

			.wp-night-mode-button.active .wp-night-mode-slider {
				background-color: ;
			}

			body.wp-night-mode-on * {
				background: #2d2d2d;
			}

			body.wp-night-mode-on .customize-partial-edit-shortcut button,
			body.wp-night-mode-on .customize-partial-edit-shortcut button svg,
			body.wp-night-mode-on #adminbarsearch,
			body.wp-night-mode-on span.display-name,
			body.wp-night-mode-on span.ab-icon,
			body.wp-night-mode-on span.ab-label {
			    background: transparent;
			}

			body.wp-night-mode-on * {
				color: #ffffff;
			}

			body.wp-night-mode-on a {
				color: #ffffff;
			}

			body.wp-night-mode-on a:hover,
			body.wp-night-mode-on a:visited,
			body.wp-night-mode-on a:active {
				color: #ffffff;
			}
		}				}
			</style>
		<style type='text/css'>img#wpstats{display:none}</style>
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;" />
<meta property="og:url" content="https://www.theedgesusu.co.uk/film/2022/05/05/interview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives/" />
<meta property="og:description" content="Editor, Sam Pegg, interviews EFN&#8217;s Erifili Missiou about the film festival hoping to shake things up this year for emerging talent." />
<meta property="article:published_time" content="2022-05-05T10:18:33+00:00" />
<meta property="article:modified_time" content="2022-05-05T10:19:01+00:00" />
<meta property="og:site_name" content="The Edge" />
<meta property="og:image" content="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/Screenshot-2022-04-19-at-19.38.40.jpg" />
<meta property="og:image:width" content="1478" />
<meta property="og:image:height" content="770" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_GB" />
<meta name="twitter:text:title" content="Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;" />
<meta name="twitter:image" content="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/Screenshot-2022-04-19-at-19.38.40.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://www.theedgesusu.co.uk/wp-content/uploads/2020/02/cropped-edge-logo-32x32.gif" sizes="32x32" />
<link rel="icon" href="https://www.theedgesusu.co.uk/wp-content/uploads/2020/02/cropped-edge-logo-192x192.gif" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.theedgesusu.co.uk/wp-content/uploads/2020/02/cropped-edge-logo-180x180.gif" />
<meta name="msapplication-TileImage" content="https://www.theedgesusu.co.uk/wp-content/uploads/2020/02/cropped-edge-logo-270x270.gif" />
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script><link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://www.theedgesusu.co.uk/?custom-css=1646f8fde0" />	
<!--[if lt IE 9]>
<script src="https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/js/html5.js" type="text/javascript"></script>
<![endif]-->
</head>

<body class="post-template-default single single-post postid-175418 single-format-standard page-builder _masterslider _ms_version_3.8.1 right-sidebar full">
<div class="main-wrap">

	
	
	<div class="top-bar">

		<div class="wrap">
			<section class="top-bar-content">
			
								<div class="trending-ticker">
					<span class="heading">Read more</span>

					<ul>
												
												
							<li><a href="https://www.theedgesusu.co.uk/film/2022/05/05/interview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives/" title="Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;">Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/live/previews/2022/05/05/preview-the-goa-express-heartbreakers-southampton-13-05-2022/" title="Preview: The Goa Express @ Heartbreakers, Southampton 13/05/2022">Preview: The Goa Express @ Heartbreakers, Southampton 13/05/2022</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/culture/2022/05/05/review-footloose-mayflower-theatre/" title="Review: Footloose @ Mayflower Theatre">Review: Footloose @ Mayflower Theatre</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/news/2022/05/03/nostalgic-news-fear-is-25-years-old/" title="Nostalgic News: Fear is 25 years old">Nostalgic News: Fear is 25 years old</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/news/2022/05/03/the-edge-announces-noughties-magazine-fundraiser-16-5-22/" title="The Edge Announces&#8230; Noughties Magazine Fundraiser 16/5/22">The Edge Announces&#8230; Noughties Magazine Fundraiser 16/5/22</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/news/2022/04/29/nostalgic-news-chief-keef-i-dont-like/" title="Nostalgic News: Chief Keef &#8211; I Don&#8217;t Like">Nostalgic News: Chief Keef &#8211; I Don&#8217;t Like</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/live/reviews/2022/04/29/review-feeder-o2-guildhall-southampton-26-4-22/" title="Review: Feeder @ O2 Guildhall Southampton, 26/4/22">Review: Feeder @ O2 Guildhall Southampton, 26/4/22</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/film/cinema/2022/04/23/review-the-northman-historical-epic-goes-above-and-beyond/" title="Review: The Northman &#8211; Historical epic goes above and beyond">Review: The Northman &#8211; Historical epic goes above and beyond</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/film/2022/04/22/the-hawaiian-shirt-in-film/" title="The Hawaiian Shirt in Film">The Hawaiian Shirt in Film</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/live/previews/2022/04/20/preview-feeder-o2-guildhall-southampton-26-04-22/" title="Preview: Feeder @ O2 Guildhall Southampton, 26.04.22">Preview: Feeder @ O2 Guildhall Southampton, 26.04.22</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/film/2022/04/18/collab-favourite-film-scores/" title="Collab: Favourite Film Scores">Collab: Favourite Film Scores</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/records/albums/2022/04/17/truly-accomplished-in-every-shape-and-form-a-review-of-lizzy-mcalpines-five-seconds-flat/" title="&#8216;Truly accomplished in every shape and form&#8217;: A Review of Lizzy McAlpine&#8217;s &#8216;five seconds flat&#8217;">&#8216;Truly accomplished in every shape and form&#8217;: A Review of Lizzy McAlpine&#8217;s &#8216;five seconds flat&#8217;</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/records/albums/2022/04/16/wasted-potential-a-review-of-fivio-foreigns-b-i-b-l-e/" title="Wasted potential: A Review of Fivio Foreign&#8217;s B.I.B.L.E.">Wasted potential: A Review of Fivio Foreign&#8217;s B.I.B.L.E.</a></li>
						
												
							<li><a href="https://www.theedgesusu.co.uk/records/albums/2022/04/15/one-of-the-best-records-of-2022-so-far-a-review-of-billy-woods-aethiopes/" title="&#8216;One of the best records of 2022 so far&#8217;: A Review of billy woods&#8217; Aethiopes">&#8216;One of the best records of 2022 so far&#8217;: A Review of billy woods&#8217; Aethiopes</a></li>
						
												
											</ul>
				</div>
				
				
				<div class="search">
					<form role="search" action="https://www.theedgesusu.co.uk/" method="get">
						<input type="text" name="s" class="query" value="" placeholder="Search..." />
						<button class="search-button" type="submit"><i class="fa fa-search"></i></button>
					</form>
				</div> <!-- .search -->
								
			</section>
		</div>
		
	</div>
	
	
	<div id="main-head" class="main-head">
		
		<div class="wrap">
		
			<header>
				<div class="title">
				
				<a href="https://www.theedgesusu.co.uk/" title="The Edge" rel="home">
									
					<img src="https://www.theedgesusu.co.uk/wp-content/uploads/2017/07/The-Edge-Logo_Black-e1498892715797.png" class="logo-image" alt="The Edge" data-at2x="https://www.theedgesusu.co.uk/wp-content/uploads/2017/07/The-Edge-Logo_Black-e1498892715797.png" />
						 
								</a>
				
				</div>
				
				<div class="right">
								<div class="textwidget"><div id="fblike" class="fb-like" data-href="https://www.facebook.com/theedgesusu" data-layout="standard" data-action="like" data-show-faces="false" data-share="false">
</div> <br>


<p style="text-align:left; line-height: 1.1;">The University of Southampton's entertainment magazine.</p>


</div>
						</div>
			</header>
			
						
			<nav class="navigation cf" data-sticky-nav="1">
			
				<div class="mobile" data-type="classic" data-search="1">
					<a href="#" class="selected">
						<span class="text">Navigate</span><span class="current"></span> <i class="hamburger fa fa-bars"></i>
					</a>
				</div>
				
				<div class="menu-menu-thea-edition-container"><ul id="menu-menu-thea-edition" class="menu"><li id="menu-item-137518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-137518"><a href="https://www.theedgesusu.co.uk/">Home</a></li>
<li id="menu-item-137539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-6543 menu-item-137539"><a href="https://www.theedgesusu.co.uk/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-159161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-25970 menu-item-159161"><a href="https://www.theedgesusu.co.uk/category/news/local-news/">Local News</a></li>
	<li id="menu-item-159160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-25969 menu-item-159160"><a href="https://www.theedgesusu.co.uk/category/news/global-news/">Global News</a></li>
	<li id="menu-item-163151" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-26590 menu-item-163151"><a href="https://www.theedgesusu.co.uk/category/news/nostalgic-news/">Nostalgic News</a></li>
	<li id="menu-item-159182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-25971 menu-item-159182"><a href="https://www.theedgesusu.co.uk/category/news/wekkly-roundups-news/">Weekly Roundups</a></li>
</ul>
</li>
<li id="menu-item-137522" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-9 menu-item-137522"><a href="https://www.theedgesusu.co.uk/category/culture/">Culture</a>
<ul class="sub-menu">
	<li id="menu-item-137523" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22362 menu-item-137523"><a href="https://www.theedgesusu.co.uk/category/culture/features-culture/">Features</a></li>
	<li id="menu-item-137524" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22368 menu-item-137524"><a href="https://www.theedgesusu.co.uk/category/culture/interviews-culture/">Interviews</a></li>
	<li id="menu-item-137526" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-47 menu-item-137526"><a href="https://www.theedgesusu.co.uk/category/culture/television/">Television</a></li>
	<li id="menu-item-137528" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-283 menu-item-137528"><a href="https://www.theedgesusu.co.uk/category/culture/video-games/">Video Games</a></li>
	<li id="menu-item-137525" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-446 menu-item-137525"><a href="https://www.theedgesusu.co.uk/category/culture/literature/">Literature</a></li>
	<li id="menu-item-146907" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-24524 menu-item-146907"><a href="https://www.theedgesusu.co.uk/category/culture/art/">Art</a></li>
	<li id="menu-item-137527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-471 menu-item-137527"><a href="https://www.theedgesusu.co.uk/category/culture/theatre/">Theatre</a></li>
	<li id="menu-item-159159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-26042 menu-item-159159"><a href="https://www.theedgesusu.co.uk/category/culture/podcasts/">Podcasts</a></li>
</ul>
</li>
<li id="menu-item-137529" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-cat-6544 menu-item-137529"><a href="https://www.theedgesusu.co.uk/category/film/">Film</a>
<ul class="sub-menu">
	<li id="menu-item-137532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22366 menu-item-137532"><a href="https://www.theedgesusu.co.uk/category/film/features-film/">Features</a></li>
	<li id="menu-item-137533" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-22367 menu-item-137533"><a href="https://www.theedgesusu.co.uk/category/film/interviews-film/">Interviews</a></li>
	<li id="menu-item-137530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-442 menu-item-137530"><a href="https://www.theedgesusu.co.uk/category/film/cinema/">Cinema</a></li>
	<li id="menu-item-137531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-65 menu-item-137531"><a href="https://www.theedgesusu.co.uk/category/film/dvd-bluray/">DVD &amp; Blu-Ray</a></li>
</ul>
</li>
<li id="menu-item-137534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-6545 menu-item-137534"><a href="https://www.theedgesusu.co.uk/category/live/">Live</a>
<ul class="sub-menu">
	<li id="menu-item-137535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22365 menu-item-137535"><a href="https://www.theedgesusu.co.uk/category/live/features-live/">Features</a></li>
	<li id="menu-item-137537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22369 menu-item-137537"><a href="https://www.theedgesusu.co.uk/category/live/interviews-live/">Interviews</a></li>
	<li id="menu-item-137538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-19 menu-item-137538"><a href="https://www.theedgesusu.co.uk/category/live/reviews/">Reviews</a></li>
	<li id="menu-item-137536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-10397 menu-item-137536"><a href="https://www.theedgesusu.co.uk/category/live/festivals/">Festivals</a></li>
	<li id="menu-item-146906" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-24513 menu-item-146906"><a href="https://www.theedgesusu.co.uk/category/live/dance/">Dance</a></li>
</ul>
</li>
<li id="menu-item-137540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-5884 menu-item-137540"><a href="https://www.theedgesusu.co.uk/category/records/">Records</a>
<ul class="sub-menu">
	<li id="menu-item-137542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22364 menu-item-137542"><a href="https://www.theedgesusu.co.uk/category/records/features-records/">Features</a></li>
	<li id="menu-item-137543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-22370 menu-item-137543"><a href="https://www.theedgesusu.co.uk/category/records/interviews-records/">Interviews</a></li>
	<li id="menu-item-137541" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-17 menu-item-137541"><a href="https://www.theedgesusu.co.uk/category/records/albums/">Albums</a></li>
	<li id="menu-item-137544" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-15 menu-item-137544"><a href="https://www.theedgesusu.co.uk/category/records/singles/">Singles</a></li>
</ul>
</li>
<li id="menu-item-137519" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-137519"><a href="https://www.theedgesusu.co.uk/contact-us/">Contact Us</a>
<ul class="sub-menu">
	<li id="menu-item-137521" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137521"><a href="https://www.theedgesusu.co.uk/getting-started-writing-for-the-edge/">Join Us</a></li>
	<li id="menu-item-137520" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137520"><a href="https://www.theedgesusu.co.uk/contact-us/committee-details/">Meet the Committee</a></li>
</ul>
</li>
<li id="menu-item-159716" class="wp-night-mode menu-item menu-item-type-custom menu-item-object-custom menu-item-159716"><a href="#">Night Mode</a></li>
</ul></div>			</nav>
			
		</div>
		
	</div>
	
	<div class="wrap">
		<div class="breadcrumbs"><span class="location">You are at:</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.theedgesusu.co.uk/"><span itemprop="title">Home</span></a></span><span class="delim">&raquo;</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url"  href="https://www.theedgesusu.co.uk/category/film/"><span itemprop="title">Film</span></a></span><span class="delim">&raquo;</span><span class="current">Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;</span></div>	</div>


<div class="main wrap cf">
	<div class="row">
		<div class="col-8 main-content">
		
			
				
<article id="post-175418" class="post-175418 post type-post status-publish format-standard has-post-thumbnail category-film category-interviews-film tag-efn tag-erifili-missiou tag-film tag-film-festival tag-interview tag-news" itemscope itemtype="http://schema.org/Article">
	
	<header class="post-header cf">

			<div class="featured">
						
				<a href="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/Screenshot-2022-04-19-at-19.38.40.jpg" title="Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;" itemprop="image">
				
								
										
						<img width="702" height="336" src="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/Screenshot-2022-04-19-at-19.38.40-702x336.jpg" class="attachment-main-slider size-main-slider wp-post-image" alt="" title="Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;" srcset="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/Screenshot-2022-04-19-at-19.38.40-702x336.jpg 702w, https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/Screenshot-2022-04-19-at-19.38.40-1078x516.jpg 1078w" sizes="(max-width: 702px) 100vw, 702px" />					
										
								
				</a>
								
										
					<div class="caption">Credit: Adam Pietraszewski</div>
						
								
					</div>
	
		
		<h1 class="post-title" itemprop="name">
		Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;		</h1>
		
		<a href="https://www.theedgesusu.co.uk/film/2022/05/05/interview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives/#respond" class="comments"><i class="fa fa-comments-o"></i> 0</a>
		
	</header><!-- .post-header -->
	
	<div class="post-meta">
		<span class="posted-by">By 
			<span class="reviewer test123" itemprop="author">

				Sam Pegg			</span>
		</span>
		 
		<span class="posted-on">on			<span class="dtreviewed">
				<time class="value-datetime" datetime="2022-05-05T11:18:33+01:00" itemprop="datePublished">May 5, 2022</time>
			</span>
		</span>
		
		<span class="cats"><a href="https://www.theedgesusu.co.uk/category/film/" rel="category tag">Film</a>, <a href="https://www.theedgesusu.co.uk/category/film/interviews-film/" rel="category tag">Interviews</a></span>
			
	</div>
	

	<div class="post-container cf">
	
		<div class="post-content-right">
			<div class="post-content description " itemprop="articleBody">
			
				
								
				<p><span data-preserver-spaces="true">Film festivals are nothing new, and slowly the list of ones people can apply for is constantly growing. So, finding the right film festival to showcase your work is competitive, tricky, and knowing the support you&#8217;ll receive can be hard to navigate. That&#8217;s why Emerging Filmmakers Night (EFN) stands as a film festival that appeals to many people across the country and internationally. Aimed at emerging talent and &#8216;artists at the beginning of their career&#8221;, EFN was created by those &#8220;who understand the challenges of being an early career filmmaker&#8221;. In this instance, I was lucky enough to sit down with EFN&#8217;s co-founder, Erifili Missiou, and learn what made EFN the festival that should be on everyone&#8217;s radar. </span></p>
<p><span data-preserver-spaces="true"><a href="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/EFN-Clap-White-on-Black-big-1.jpg"><img class="alignleft wp-image-175419" src="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/EFN-Clap-White-on-Black-big-1.jpg" alt="" width="350" height="350" srcset="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/EFN-Clap-White-on-Black-big-1.jpg 1772w, https:&#x2f;/w&#x77;&#119;.&#x74;&#104;e&#x65;&#x64;g&#x65;&#x73;us&#x75;&#46;c&#x6f;&#46;u&#x6b;&#x2f;w&#x70;&#x2d;co&#x6e;te&#x6e;&#116;/&#x75;&#112;l&#x6f;&#x61;d&#x73;&#x2f;20&#x32;&#50;/&#x30;&#52;/&#x45;&#x46;N&#x2d;&#x43;la&#x70;&#45;W&#x68;&#105;t&#x65;&#45;o&#x6e;&#x2d;B&#x6c;&#x61;ck&#x2d;&#98;i&#x67;&#45;1&#x2d;&#x31;5&#x30;&#x78;15&#x30;&#64;2&#x78;&#46;j&#x70;&#103; 300w, https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/EFN-Clap-White-on-Black-big-1-1024x1024.jpg 1024w, https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/EFN-Clap-White-on-Black-big-1-150x150.jpg 150w, https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/EFN-Clap-White-on-Black-big-1-1536x1536.jpg 1536w, https://w&#119;&#119;&#x2e;&#x74;&#x68;&#x65;edg&#101;&#115;&#x75;&#x73;&#x75;&#x2e;co.&#117;&#107;&#x2f;&#x77;&#x70;&#x2d;con&#116;&#101;&#x6e;&#x74;&#x2f;&#x75;plo&#97;&#100;&#x73;&#x2f;&#x32;&#x30;22/0&#52;&#x2f;&#x45;&#x46;&#x4e;-Cla&#112;&#x2d;&#x57;&#x68;&#x69;te-o&#110;&#x2d;&#x42;&#x6c;&#x61;ck-b&#105;&#x67;&#x2d;&#x31;&#x2d;300x&#51;&#x30;&#x30;&#x40;&#x32;x.jp&#103; 600w" sizes="(max-width: 350px) 100vw, 350px" /></a>The first question that always comes to mind is what made EFN stand out among the growing list of film festivals. Missiou talked about how initially the festival &#8216;was created partly to provide London-based filmmakers a local platform to celebrate their work and network&#8217;, but as these things do, &#8216;over time, the scope has gotten bigger.&#8217; Missiou emphasised how &#8216;EFN was developed by creatives for creatives,&#8217; focusing on rewarding &#8216;artists at the beginning of their career&#8217; and encouraging them &#8216;to carry on.&#8217; EFN is about celebrating the work of emerging talent (much like its name states), welcoming work for &#8216;ALL filmmakers […] provided they haven&#8217;t released a feature film or long-form work at the time of submission.&#8217;</span></p>
<p><span data-preserver-spaces="true">Missiou and co-founder, Mike Sheer, put in a lot of work to ensure EFN stood out amongst the crowd in its presence and approach. &#8216;EFN combines exceptional programming with a playful attitude. We are serious about our commitment to show good films – but unafraid to be entertaining,&#8217; and that struck as refreshing and exciting for both audience members and filmmakers, using the comedic talents of Sheer to &#8216;consciously choose playfulness and a friendly atmosphere.&#8217; Yet, that doesn&#8217;t detract from the great work and notoriety of EFN, and it was assured that &#8216;filmmakers get the attention they deserve, and the audience has the opportunity to delve deeper into their process.&#8217; A significant difference between EFN and other film festivals is the work EFN does in spotlighting a filmmaker, actively choosing to hold Q&amp;As straight after a film&#8217;s screening rather than having a group at the end. Missiou constantly emphasised that they valued all the great work that makes EFN a fantastic event. They pay that back by ensuring filmmakers feel valued in every respect: from the selection process to the screenings and Q&amp;As.</span></p>
<div id="attachment_175425" style="width: 460px" class="wp-caption alignright"><a href="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/29_90770-2.jpg"><img aria-describedby="caption-attachment-175425" class="wp-image-175425" src="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/29_90770-2.jpg" alt="" width="450" height="300" srcset="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/29_90770-2.jpg 1024w, https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/29_90770-2-300x200.jpg 300w, https://w&#119;&#119;&#x2e;&#x74;&#x68;&#x65;&#x65;dge&#115;&#117;&#x73;&#x75;&#x2e;&#x63;&#x6f;.uk&#47;&#119;&#x70;&#x2d;&#x63;&#x6f;&#x6e;ten&#116;&#47;&#x75;&#x70;&#x6c;&#x6f;&#x61;ds/&#50;&#48;&#x32;&#x32;&#x2f;&#x30;&#x34;/29&#95;&#57;&#x30;&#x37;&#x37;&#x30;&#x2d;2-3&#48;&#48;&#x78;&#x32;&#x30;&#x30;&#x40;2x.&#106;&#112;&#x67; 600w" sizes="(max-width: 450px) 100vw, 450px" /></a><p id="caption-attachment-175425" class="wp-caption-text">Credit: Alessandro Mariscalco</p></div>
<p><span data-preserver-spaces="true">The work that makes EFN great doesn&#8217;t stop there, and when asked about how they encourage diversity, Missiou stated how &#8216;passionate about inclusivity and visibility&#8217; they were. EFN certainly upholds some impressive statistics that saw 10-15% of all films they screen &#8216;made by a disabled filmmaker or addresses disability&#8217; and &#8216;50% of films made by women and 30% by non-English filmmakers&#8217;. It certainly attests to Missiou&#8217;s statement that &#8216;EFN actively contributes to a healthier ecosystem in the industry,&#8217; and their push to showcase work from all backgrounds certainly feels authentic and essential in the current world. </span></p>
<p><span data-preserver-spaces="true">However, as the interview came to a close with one final question, it felt essential to consider how EFN benefits its filmmakers. Missiou talked about filmmakers&#8217; great opportunities by choosing EFN, with &#8216;each edition&#8217;s winners of our Audience Favourite and The Critics&#8217; Choice awards screened before a commercially distributed film in The Garden Cinema&#8217;. Although, Missiou assured that EFN was a collaborative festival with a &#8216;strong relationship with UK and international distributors as well as other film festivals&#8217;. What came across then was that EFN wasn&#8217;t about closing doors but opening them wide for any upcoming filmmaker, and that&#8217;s truly exciting. </span></p>
<div id="attachment_175437" style="width: 610px" class="wp-caption aligncenter"><a href="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/Screenshot-2022-04-19-at-19.40.02.jpg"><img aria-describedby="caption-attachment-175437" class="wp-image-175437" src="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/Screenshot-2022-04-19-at-19.40.02.jpg" alt="" width="600" height="342" srcset="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/Screenshot-2022-04-19-at-19.40.02.jpg 954w, https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/Screenshot-2022-04-19-at-19.40.02-300x171.jpg 300w, https:/&#x2f;w&#119;&#x77;.&#x74;&#x68;e&#x65;d&#103;&#x65;s&#117;&#x73;u&#x2e;c&#111;&#x2e;u&#107;&#x2f;w&#x70;&#x2d;c&#x6f;n&#116;&#x65;n&#x74;&#x2f;u&#x70;l&#111;&#x61;d&#115;&#x2f;2&#x30;22&#x2f;0&#52;&#x2f;S&#x63;&#x72;e&#x65;n&#115;&#x68;o&#x74;&#x2d;2&#x30;2&#50;&#x2d;0&#52;&#x2d;1&#x39;-a&#x74;-&#49;&#x39;.&#x34;&#x30;.&#x30;2&#45;&#x33;0&#x30;&#x78;1&#x37;1&#64;&#x32;x&#46;&#x6a;p&#x67; 600w" sizes="(max-width: 600px) 100vw, 600px" /></a><p id="caption-attachment-175437" class="wp-caption-text">Credit: Alessandro Mariscalco</p></div>
<p><strong>If you have a short film you want to submit to EFN, the submission deadline for regular entry is May 29th, 2022, with a later option closing on June 26th, 2022. You can submit your entry through their FilmFreeway page (<a class="editor-rtfLink" href="https://filmfreeway.com/EmergingFilmmakersNight" target="_blank" rel="noopener">https://filmfreeway.com/EmergingFilmmakersNight</a>) via. the EFN website (<a class="editor-rtfLink" href="https://www.efnfestival.org/" target="_blank" rel="noopener">https://www.efnfestival.org/</a>).</strong></p>

				
								
							</div><!-- .post-content -->
		</div>
		
	</div>
	
	
		
	<div class="post-share">
		<span class="text">Share.</span>
		
		<span class="share-links">

			<a href="http://twitter.com/home?status=https%3A%2F%2Fwww.theedgesusu.co.uk%2Ffilm%2F2022%2F05%2F05%2Finterview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives%2F" class="fa fa-twitter" title="Tweet It">
				<span class="visuallyhidden">Twitter</span></a>
				
			<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.theedgesusu.co.uk%2Ffilm%2F2022%2F05%2F05%2Finterview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives%2F" class="fa fa-facebook" title="Share on Facebook">
				<span class="visuallyhidden">Facebook</span></a>
				
			<a href="http://plus.google.com/share?url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Ffilm%2F2022%2F05%2F05%2Finterview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives%2F" class="fa fa-google-plus" title="Share on Google+">
				<span class="visuallyhidden">Google+</span></a>
				
			<a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Ffilm%2F2022%2F05%2F05%2Finterview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives%2F&amp;media=https%3A%2F%2Fwww.theedgesusu.co.uk%2Fwp-content%2Fuploads%2F2022%2F04%2FScreenshot-2022-04-19-at-19.38.40.jpg" class="fa fa-pinterest"
				title="Share on Pinterest">
				<span class="visuallyhidden">Pinterest</span></a>
				
			<a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Ffilm%2F2022%2F05%2F05%2Finterview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives%2F" class="fa fa-linkedin" title="Share on LinkedIn">
				<span class="visuallyhidden">LinkedIn</span></a>
				
			<a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.theedgesusu.co.uk%2Ffilm%2F2022%2F05%2F05%2Finterview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives%2F&amp;name=Interview%3A+EFN%26%238217%3Bs+Erifili+Missiou+%E2%80%93+A+festival+%26%238216%3Bdeveloped+by+creatives+for+creatives.%26%238217%3B" class="fa fa-tumblr"
				title="Share on Tumblr">
				<span class="visuallyhidden">Tumblr</span></a>
				
			<a href="mailto:?subject=Interview%3A%20EFN%26%238217%3Bs%20Erifili%20Missiou%20%E2%80%93%20A%20festival%20%26%238216%3Bdeveloped%20by%20creatives%20for%20creatives.%26%238217%3B&amp;body=https%3A%2F%2Fwww.theedgesusu.co.uk%2Ffilm%2F2022%2F05%2F05%2Finterview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives%2F" class="fa fa-envelope-o"
				title="Share via Email">
				<span class="visuallyhidden">Email</span></a>
			
		</span>
	</div>
	
			
</article>




	<h3 class="section-head">About Author</h3>

	            <section class="author-info">
            
                <img src='https://secure.gravatar.com/avatar/27f851c1ed4afc447b572ee7203d99e1?s=100&amp;d=http%3A%2F%2Fwww.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D100&amp;r=G' class='avatar avatar-100 avatar-default' height='100' width='100' style='width: 100px; height: 100px;' alt='avatar' />                
                <div class="description"> 
                    <a href="https://www.theedgesusu.co.uk/author/sp4g19/" title="Posts by Sam Pegg" rel="author">Sam Pegg</a>
 
                    <ul class="social-icons">
                                        </ul>
                                        <p class="bio">Previous News Editor (20-21) and now The Editor (21-22) just trying to make his way through the world of journalism... (trying being the keyword here).</p>
                </div>
                
            </section>



<section class="related-posts">
	<h3 class="section-head">Related Posts</h3> 
	<ul class="highlights-box three-col related-posts">
	
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="https://www.theedgesusu.co.uk/film/2022/04/22/the-hawaiian-shirt-in-film/" title="The Hawaiian Shirt in Film" class="image-link">
					<img width="214" height="140" src="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/leo-214x140.jpg" class="image wp-post-image" alt="" title="The Hawaiian Shirt in Film" loading="lazy" />
									</a>
				
				<div class="meta">
					<time datetime="2022-04-22T13:00:21+01:00">April 22, 2022 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="https://www.theedgesusu.co.uk/film/2022/04/22/the-hawaiian-shirt-in-film/" title="The Hawaiian Shirt in Film">The Hawaiian Shirt in Film</a></h2>
				
			</article>
		</li>
		
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="https://www.theedgesusu.co.uk/film/2022/04/18/collab-favourite-film-scores/" title="Collab: Favourite Film Scores" class="image-link">
					<img width="214" height="140" src="https://www.theedgesusu.co.uk/wp-content/uploads/2022/03/how-to-train-your-dragon-214x140.jpg" class="image wp-post-image" alt="" title="Collab: Favourite Film Scores" loading="lazy" />
									</a>
				
				<div class="meta">
					<time datetime="2022-04-18T13:00:09+01:00">April 18, 2022 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="https://www.theedgesusu.co.uk/film/2022/04/18/collab-favourite-film-scores/" title="Collab: Favourite Film Scores">Collab: Favourite Film Scores</a></h2>
				
			</article>
		</li>
		
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="https://www.theedgesusu.co.uk/film/2022/03/24/a-preview-of-2022-avatar-2/" title="In Anticipation: Avatar 2" class="image-link">
					<img width="214" height="140" src="https://www.theedgesusu.co.uk/wp-content/uploads/2022/02/Screenshot-2022-03-22-at-07.06.12-214x140.jpg" class="image wp-post-image" alt="" title="In Anticipation: Avatar 2" loading="lazy" />
									</a>
				
				<div class="meta">
					<time datetime="2022-03-24T09:00:16+00:00">March 24, 2022 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="https://www.theedgesusu.co.uk/film/2022/03/24/a-preview-of-2022-avatar-2/" title="In Anticipation: Avatar 2">In Anticipation: Avatar 2</a></h2>
				
			</article>
		</li>
		
		</ul>
</section>

				<div class="comments">
				
	
	<div id="comments">

		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span class="section-head">Leave A Reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/film/2022/05/05/interview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://www.theedgesusu.co.uk/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
			<p>
				<textarea name="comment" id="comment" cols="45" rows="8" aria-required="true" placeholder="Your Comment"></textarea>
			</p>
				<p>
					<input name="author" id="author" type="text" value="" size="30" aria-required="true" placeholder="Your Name" />
				</p>

				<p>
					<input name="email" id="email" type="text" value="" size="30" aria-required="true" placeholder="Your Email" />
				</p>
			

				<p>
					<input name="url" id="url" type="text" value="" size="30" placeholder="Your Website" />
				</p>
			
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='175418' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1dc0e1280e" /></p>
<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf1N='f5a6757dc6a257b328d3d4f8c55f7593';
hf1V='e1e711ca3c227a67c0587a44962aa963';
document.write("<input type='hidden' name='r3f5x9JS' value='"+r3f5x9JS+"' /><input type='hidden' name='"+hf1N+"' value='"+hf1V+"' />");
/* ]]> */
</script>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
<p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="184"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
				</div>

			
		</div>

		
			
		
		<aside class="col-4 sidebar">
			<ul>
			
			<li id="wpcom_social_media_icons_widget-3" class="widget widget_wpcom_social_media_icons_widget"><h3 class="widgettitle">Find us on Social Media!</h3><ul><li><a href="https://www.facebook.com/theedgesusu/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View theedgesusu&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/theedgesusu/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View theedgesusu&#8217;s profile on Twitter</span></a></li><li><a href="https://www.instagram.com/theedgesusu/" class="genericon genericon-instagram" target="_blank"><span class="screen-reader-text">View theedgesusu&#8217;s profile on Instagram</span></a></li><li><a href="https://www.twitch.tv/theedgesusu/" class="genericon genericon-twitch" target="_blank"><span class="screen-reader-text">View theedgesusu&#8217;s profile on Twitch</span></a></li></ul></li>
<li id="text-11" class="widget widget_text"><h3 class="widgettitle">Read our latest issue here:</h3>			<div class="textwidget"><div style="height: 420px;"><iframe src="https://drive.google.com/file/d/115OzBTIgq0MTw7UINBvY07drxI65AOOm/preview" height="100%"></iframe></div>
<p><!-- just replace the link in the speech marks after src= with the latest edition's google drive link, with the /preview on the end. e.g a link like this one https://drive.google.com/file/d/1JKADLRREHF4Kw9KbojeFso8UjCPcxPbU/preview --></p>
</div>
		</li>
<li id="text-14" class="widget widget_text"><h3 class="widgettitle">Read our mini mag here:</h3>			<div class="textwidget"><div style="height: 420px;"><iframe src="https://drive.google.com/file/d/1iSo4RFOP91e0l4thcpz2WUbfaUJ3oze0/preview" height="100%"></iframe></div>
<p><!-- just replace the link in the speech marks after src= with the latest edition's google drive link, with the /preview on the end. e.g a link like this one https://drive.google.com/file/d/1JKADLRREHF4Kw9KbojeFso8UjCPcxPbU/preview --></p>
</div>
		</li>
<li id="text-13" class="widget widget_text"><h3 class="widgettitle">Read our collaborative issue here:</h3>			<div class="textwidget"><div style="height: 420px;"><iframe src="https://drive.google.com/file/d/18TGpLpJPHw3YW7DmGLd8B8Y4KOvZE_Ol/preview" height="100%"></iframe></div>
<p><!-- just replace the link in the speech marks after src= with the latest edition's google drive link, with the /preview on the end. e.g a link like this one https://drive.google.com/file/d/1JKADLRREHF4Kw9KbojeFso8UjCPcxPbU/preview --></p>
</div>
		</li>
<li id="text-16" class="widget widget_text">			<div class="textwidget"><p><script type="text/javascript" src="https://www.crowdfunder.co.uk/p/noughties/widget"></script></p>
</div>
		</li>
<li id="text-9" class="widget widget_text"><h3 class="widgettitle">Check Out What We&#8217;re Listening To:</h3>			<div class="textwidget"><p><iframe title="Spotify Embed: Guilty Pleasure Tracks" style="border-radius: 12px" width="100%" frameborder="0" allowfullscreen allow="autoplay; clipboard-write; encrypted-media; fullscreen; picture-in-picture" src="https://open.spotify.com/embed/playlist/5vPpYfeNTbUvPRqJLWyJIp?utm_source=oembed"></iframe></p>
<p><iframe src="https://anchor.fm/the-edge4/embed/episodes/WandaVision-es93tf"  frameborder="0" scrolling="no"></iframe></p>
</div>
		</li>

			<li id="bunyad-latest-posts-widget-2" class="widget latest-posts">			
							<h3 class="widgettitle">Recent Posts</h3>						
			<ul class="posts-list">
			
							<li>
				
					<a href="https://www.theedgesusu.co.uk/film/2022/05/05/interview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives/"><img width="110" height="96" src="https://www.theedgesusu.co.uk/wp-content/uploads/2022/04/Screenshot-2022-04-19-at-19.38.40-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;" loading="lazy" />					
										
					</a>
					
					<div class="content">
					
						<time datetime="2022-05-05T11:18:33+01:00">May 5, 2022 </time>
					
						<span class="comments"><a href="https://www.theedgesusu.co.uk/film/2022/05/05/interview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="https://www.theedgesusu.co.uk/film/2022/05/05/interview-efns-erifili-missiou-a-festival-developed-by-creatives-for-creatives/" title="Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;">
							Interview: EFN&#8217;s Erifili Missiou – A festival &#8216;developed by creatives for creatives.&#8217;</a>
							
																							
					</div>
				
				</li>
							<li>
				
					<a href="https://www.theedgesusu.co.uk/live/previews/2022/05/05/preview-the-goa-express-heartbreakers-southampton-13-05-2022/"><img width="110" height="96" src="https://www.theedgesusu.co.uk/wp-content/uploads/2022/05/the-goa-express-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Preview: The Goa Express @ Heartbreakers, Southampton 13/05/2022" loading="lazy" />					
										
					</a>
					
					<div class="content">
					
						<time datetime="2022-05-05T10:00:30+01:00">May 5, 2022 </time>
					
						<span class="comments"><a href="https://www.theedgesusu.co.uk/live/previews/2022/05/05/preview-the-goa-express-heartbreakers-southampton-13-05-2022/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="https://www.theedgesusu.co.uk/live/previews/2022/05/05/preview-the-goa-express-heartbreakers-southampton-13-05-2022/" title="Preview: The Goa Express @ Heartbreakers, Southampton 13/05/2022">
							Preview: The Goa Express @ Heartbreakers, Southampton 13/05/2022</a>
							
																							
					</div>
				
				</li>
							<li>
				
					<a href="https://www.theedgesusu.co.uk/culture/2022/05/05/review-footloose-mayflower-theatre/"><img width="110" height="96" src="https://www.theedgesusu.co.uk/wp-content/uploads/2022/05/Footloose_Title4_1920x1080-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Review: Footloose @ Mayflower Theatre" loading="lazy" />					
										
					</a>
					
					<div class="content">
					
						<time datetime="2022-05-05T10:00:07+01:00">May 5, 2022 </time>
					
						<span class="comments"><a href="https://www.theedgesusu.co.uk/culture/2022/05/05/review-footloose-mayflower-theatre/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="https://www.theedgesusu.co.uk/culture/2022/05/05/review-footloose-mayflower-theatre/" title="Review: Footloose @ Mayflower Theatre">
							Review: Footloose @ Mayflower Theatre</a>
							
																							
					</div>
				
				</li>
						</ul>
			
			</li>
	
			</ul>
		</aside>
		
			
	</div> <!-- .row -->
</div> <!-- .main -->

<div id='avatar_footer_credit' style='display: none;'>Avatars by <a href='http://www.sterling-adventures.co.uk/blog/'>Sterling Adventures</a></div>
		
	<footer class="main-footer">
	
		
	
			<div class="lower-foot">
			<div class="wrap">
		
						
			<div class="widgets">
				<div class="menu-footer-navigation-container"><ul id="menu-footer-navigation" class="menu"><li id="menu-item-106636" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-106636"><a href="https://docs.google.com/forms/d/e/1FAIpQLSdo5YmhvZyw-gS-MpbCBiQ1XxYcdD2AL1PfDdqvSvRbtkuEUw/viewform">Register/Forgot Password</a></li>
<li id="menu-item-57232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57232"><a href="http://www.theedgesusu.co.uk/wp-admin">Writer Login</a></li>
</ul></div>			</div>
			
					
			</div>
		</div>		
		
	</footer>
	
</div> <!-- .main-wrap -->


<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='f5a6757dc6a257b328d3d4f8c55f7593';
hf4V='e1e711ca3c227a67c0587a44962aa963';
cm4S="form[action='https://www.theedgesusu.co.uk/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form, .wpcf7-form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});});
/* ]]> */
</script> 
	<div style="display:none">
			<div class="grofile-hash-map-27f851c1ed4afc447b572ee7203d99e1">
		</div>
		</div>
		<link rel='stylesheet' id='genericons-css'  href='https://www.theedgesusu.co.uk/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/imgareaselect/jquery.imgareaselect.min.js?ver=5.9.3' id='imgareaselect-js'></script>
<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.theedgesusu.co.uk\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/comment-reply.min.js?ver=5.9.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/www.theedgesusu.co.uk\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.5.6' id='contact-form-7-js'></script>
<script type='text/javascript' id='bunyad-theme-js-extra'>
/* <![CDATA[ */
var Bunyad = {"ajaxurl":"https:\/\/www.theedgesusu.co.uk\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/js/bunyad-theme.js?ver=2.3.0' id='bunyad-theme-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/themes/smart-mag/js/jquery.flexslider-min.js?ver=2.3.0' id='flex-slider-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/master-slider/public/assets/js/jquery.easing.min.js?ver=3.8.1' id='jquery-easing-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/master-slider/public/assets/js/masterslider.min.js?ver=3.8.1' id='masterslider-core-js'></script>
<script type='text/javascript' src='https://www.theedgesusu.co.uk/wp-content/plugins/wp-spamshield/js/jscripts-ftr2-min.js' id='wpss-jscripts-ftr-js'></script>
<script src='https://stats.wp.com/e-202218.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'15861055',post:'175418',tz:'1',srv:'www.theedgesusu.co.uk'} ]);
	_stq.push([ 'clickTrackerInit', '15861055', '175418' ]);
</script>
</body>
</html>